Installation

Installation of the Nextmv Platform

A tutorial for installing components of the Nextmv Platform.

Please find the following sections for installing Nextmv Platform components:

Nextmv is available for macOS and Linux. For Windows users, we recommend the use of WSL.

If you have any questions, please contact support.

Nextmv CLI

The Nextmv CLI is a command line interface that lets you easily interact with the other components of the Nextmv Platform.

Export your Nextmv API key as an environment variable:

export NEXTMV_API_KEY="<YOUR-API-KEY>"
Copy

Run the following script to install Nextmv CLI:

export NEXTMV_BASE_URL=https://api.cloud.nextmv.io
curl -sS "https://cloud.nextmv.io/install-cli.txt" | bash -
Copy

After downloading and installing, the last step is to configure Nextmv CLI with your account:

nextmv configure --api-key $NEXTMV_API_KEY
Copy

To display more information about a command, use help or the --help, -h flags.

nextmv help
Copy

Nextmv Go SDK

Nextmv Go SDK provides a set of APIs to build decision models. It also comes with a set of community apps for solving domain-specific optimization problems. Community apps include everything needed to run a model and can be used as the foundation for building a custom decision app.

First, let’s use Nextmv CLI to install Nextmv SDK locally. The following command will install Go and get the necessary plugins and other supporting files needed to build and run custom models locally.

Nextmv SDK manages its own Go installation and will not affect your current Go installation, if you have one.

nextmv sdk install
Copy

If you’re on macOS you may need to run a command to allow access to Nextmv SDK. This command will be output at the end of the installation process.

Nextmv Python SDK

nextmv-py is the Python SDK, a package to interact programmatically with the Nextmv Platform from Python. It is hosted on PyPI. Python >=3.10 is required.

Install via pip:

pip install nextmv
Copy

VSCode

While not required, we recommend all users install VSCode as their code editor and the VSCode Go Extension. Windows users would also need to install the VSCode wsl extension.

https://code.visualstudio.com/download
Copy

WSL for Windows users

Install WSL for Windows. You can find the installation instructions here. We recommend using Ubuntu.

wsl --install
Copy

If this is your first time installing WSL, you may receive an error when running a Nextmv template stating that you need gcc installed. In order to do so, you have to run:

sudo apt update 

sudo apt install build-essential
Copy

Page last updated

Go to on-page nav menu